Watir 7.0 Beta 2

Watir 7.0.0.beta2 is now available on RubyGems. This is all the additions and optimizations that were dependent on removing the deprecated code in Beta 1. Watir Repo now has zero outstanding bugs! The Issues list contains 2 optimizations and 2 feature requests which we may or may not get to before Watir 7.0 is released. Expect production release of Watir 7.0 as soon as Selenium 4.0 is released.
Continue Reading...
Written by: Titus Fortner on March 26, 2021

Watir 7.0 Beta 1

Watir 7.0.0.beta1 is now available on RubyGems. Watir 7 is coming! Since Watir 7.0 will require Selenium 4.0, this beta release requires at least Selenium 4 beta 2. In spite of being pre-release versions, we recommend using these beta releases over the latest production releases of Watir 6 and Selenium 3. A lot of deprecated code was removed, so please run your tests with Watir 6.19.1 and make sure you don’t have any deprecation warnings before trying this beta. Please let us know if anything is not working the way you expect it to.
Continue Reading...
Written by: Titus Fortner on March 18, 2021

Watir 6.19

Watir 6.19 is now available on RubyGems. Unless there are any bugs found, this will be the last 6.x release. Watir 7.0 will be based on Selenium 4.0, so expect some beta versions of Watir 7, so long as Selenium remains in beta status. That said, Selenium 4 beta is extremely stable and is highly encouraged at this point. This release fixes numerous limitations and bugs in staring a Watir Browser, and deprecates a number of things to prepare for Watir 7’s and Selenium 4’s way of starting the Browser/Driver.
Continue Reading...
Written by: Titus Fortner on March 12, 2021