Poll: what Ruby/Watir versions do you use?

The Watir Team is trying to work out which versions of Ruby and which versions of Watir to support, and it was suggested we run a poll to see.

I didn’t realize there’s been so many versions of Watir:

  1. 1.8.0.rc1 February 25, 2011
  2. 1.7.1 January 9, 2011
  3. 1.7.0 January 5, 2011
  4. 1.7.0.rc1 December 20, 2010
  5. 1.6.7 October 26, 2010
  6. 1.6.7.rc1 October 21, 2010
  7. 1.6.6 October 2, 2010
  8. 1.6.6.rc2 September 30, 2010
  9. 1.6.6.rc1 September 24, 2010
  10. 1.6.5 November 10, 2009
  11. 1.6.2 November 6, 2008
  12. 1.5.6 June 10, 2008
  13. 1.5.5 June 9, 2008
  14. 1.5.4 April 23, 2008
  15. 1.5.3 October 22, 2007
  16. 1.5.2 September 3, 2007
  17. 1.4.1 August 22, 2005

Plus, there’s Ruby versions 1.8.6, 1.8.7, 1.9.1 and 1.9.2., so this means there’s a large number of combinations to support.

So, take a moment and let us know which Ruby Version and Watir Version you use.

Open a command prompt to determine your Ruby version: ruby -v

And to determine your Watir version: gem list watir

Thanks!

2 thoughts on “Poll: what Ruby/Watir versions do you use?

  1. Whatever happens going forward, I will need modal support. I’m testing mission critical data center monitoring modules that host a web server among other protocol. The are many warning and Alert popups on every page.

    • Are you sure that these are so-called modal dialogs and not just some regular popups or even javascript popups? Modal dialogs are very specific “popups”… Just so you know.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s